仮想化生活への軌跡

Feed Rss


Ubuntu Server 14.04 LTS amd64でapt-get updateできない?

04.20.2014, Ubuntu Server, by .

先日ESXiに試験導入したUbuntu Server 14.04 LTS amd64ですが、apt-get updateが正常に完了せず、apt-get installコマンドによるパッケージインストールも失敗する現象に遭遇しています。

註)twitter上の情報をもとに暫定的対処法をまとめました。


現象

コマンドラインからapt-get updateを実行すると下記のようなエラーが表示されます。
(...省略...)
13.6 MB を 11秒 で取得しました (1,220 kB/s)
W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_trusty_universe_source_Sources の取得に失敗しました  ハッシュサムが適合しません

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_trusty_main_binary-amd64_Packages の取得に失敗しました  ハッシュサムが適合しません

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_trusty_universe_binary-i386_Packages の取得に失敗しました  ハッシュサムが適合しません

E: いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。


また、apt-get installコマンドによる一部のパッケージインストールが下記のようなエラーメッセージとともに失敗します。

例:”git”のインストールを試みた場合



root@test:~# apt-get install git
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています
状態情報を読み取っています… 完了
インストールすることができないパッケージがありました。おそらく、あり得
ない状況を要求したか、(不安定版ディストリビューションを使用しているの
であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
動されていないことが考えられます。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージには満たせない依存関係があります:
git:i386 : 依存: perl-modules:i386 しかし、インストールすることができません
依存: liberror-perl:i386 しかし、インストールすることができません
依存: git-man:i386 (> 1:1.9.1) しかし、インストールすることができません
依存: git-man:i386 (< 1:1.9.1-.) しかし、インストールすることができません
E: 問題を解決することができません。壊れた変更禁止パッケージがあります。
[/shell]
インストールに成功するパッケージもある上、apt-get updateの失敗との因果関係も不明です。

幾度もの再インストールやネット上の情報検索を試みましたが、現状のところ問題解決の手掛かりは得られていません。

仮にUbuntuのバグやレポジトリサーバ側の不具合に起因するものであるならば暫く静観するほかなさそうです。


Advertisement


RelatingPosts

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です


*